[Catalyst] Problems in make tests of Catalyst::Controller::FormBuilder 0.03

Alejandro Imass alejandro.imass at gmail.com
Wed Mar 21 23:34:28 GMT 2007

I also tried with the version on svn and the same thing happens. I
tried several things before writing to the list but without any luck.

Just out of curiosity, how does this

my $page = "books/basic";
$mech->get_ok( "http://localhost/$page", "GET /$page" );

know if it's goint to use the mason, template or tt2 version of
books/basic? and also, if I have another http server running on
localhost should this test pass? (I shut down my local apache just in
case, again without luck):

Oh and BTW, even though the error is in:

ok( $form, "Form found" ) or BAIL_OUT("Can't do anything without a form");

there is a warning on the $mech->get_ok() that I could not figire out.
Where could I have gotten more info on this 'fieldsubs' option
mentiones on the warning? I looked at the doc for many of the modules
involved and could not find any info on this.

Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/00-load.t
t/01-basic.t t/02-edit.t t/03-attr_param.t
t/00-load..........ok 1/1# Testing Catalyst::Controller::FormBuilder 0.03
t/01-basic.........[Test::WWW::Mechanize::get_ok] Warning: Possible
field access via $form->prepare() - see 'fieldsubs' option at
t/01-basic.t line 11
t/01-basic.........NOK 2
#   Failed test 'Form found'
#   in t/01-basic.t at line 14.
FAILED--Further testing stopped: Can't do anything without a form
make: *** [test_dynamic] Error 9
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force

Running catalyst 5.7006 installed from CPAN on Debian Linux.

Any help greatly appreciated!


More information about the Catalyst mailing list