[Catalyst] Catalyst::Manual::Cookbook and/or Catalyst::Model::CDBI::CRUD issue

Lars Balker Rasmussen lars at balker.dk
Mon Jun 13 06:26:27 CEST 2005

samwyse wrote:
> "Scaffolding is very simple with Catalyst. Just use
> Catalyst::Model::CDBI::CRUD as your base class."
> OK, I followed the example and got this:  <<Caught exception "Can't
> locate object method "columns" via package
> "MyApp::Model::MyCDBI::User" (perhaps you forgot to load
> "MyApp::Model::MyCDBI::User"?) at
> /home/dentos/MyApp/script/../lib/MyApp.pm line 105.">>
> This seems in accordance with the cookbook examples, so I'm unsure
> what the problem is.  I've spent a fair amount of the weekend reading
> various packages that may or may not be connected, without much
> progress (although I guess I haven't tried following the ISA chain of
> my class to verify its ancestory).

I wrote on the 29th:
: Trying to follow the scaffolding example in the cookbook, I ran into
: some problems, as documented on http://balker.dk/Catalyst-CRUD
: Obviously the cookbook is lacking a call to MyApp->setup, and possibly : a
:     sub end : Private {
:         $c->forward('MyApp::V::TT');
:     }
: but besides this, why do I get the error 'Couldn't forward to
: "MyApp::M::CDBI::Magasin". Invalid or not loaded.'?
: MyApp::M::CDBI::Magasin is not in %INC, despite it's a "Loaded
: component".
: Is it my installation (FreeBSD ports, excluding C::M::CDBI::CRUD which
: coincidentally I'm turning into a port right now.) that's broken?  Can
: anyone reproduce this bug?

IT appears to be the same problem.  The consensus seems to be: Don't use 
the CRUD module.
Lars Balker Rasmussen                             Consult::Perl

More information about the Catalyst mailing list